using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b[A-z]+(?=(, )|( or )|$)";
string input = @"Hit that thing man! and a one, two, three, four, five, six, seven or eight";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}