import Foundation
let pattern = #"(<a[^href]*href=["']{2}[^>]*>)([^<>]*|.*)(<\/a>)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
this is a bet and he is <a id="sss" href='' dfsd fdg >Mansoon</a> and he please search on <a href='http://www.google.com'>Google</a> and say he <a href=''>Yammy</a>
<a href=''> <i>Yammy </i> <br/> </a>
this is a bet and he is Mansoon and he please search on <a href='http://www.google.com'>Google</a> and say he Yammy
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)