using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\+33|\(\+33\)|0)(?:-| |)([0-9]{1})(?:-| |)([0-9]{2})(?:-| |)([0-9]{2})(?:-| |)([0-9]{2})(?:-| |)([0-9]{2})";
string substitution = @"0$1 $2 $3 $4 $5";
string input = @"0123456789
+33123456789
(+33)4 98 74 44 44
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}