package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:\+33|\(\+33\)|0)(?:-| |)([0-9]{1})(?:-| |)([0-9]{2})(?:-| |)([0-9]{2})(?:-| |)([0-9]{2})(?:-| |)([0-9]{2})`)
var str = `0123456789
+33123456789
(+33)4 98 74 44 44
`
var substitution = "0$1 $2 $3 $4 $5"
fmt.Println(re.ReplaceAllString(str, substitution))
}