Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Regular
Expressions
101
Regular
Expressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
\/(watch\?v=|embed\/)([\d\w-_]+)
/
gm
Test String
New
aaa@adasd.com adas@asdas.com.br https://www.youtube.com/watch?v=C8UMTmUbxTI http://www.youtube.com/watch?v=C8UMTmUbxTI www.youtube.com/embed/C8UMTmUbxTI www.youtube.com.br/embed/C8UMTmUbxTI?rel=0 m.youtube.com/watch?v=C8UMTmUbxTI