import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d+)[\\w-]+\\.jpg";
final String string = "101018-202x300.jpg\n"
+ "100116-215x300.jpg\n"
+ "1000748-300x157.jpg\n"
+ "100138-196x300.jpg\n"
+ "100308-companion-in-surgical-studies-208x300.jpg\n"
+ "100463-Ambroise-Pare-300x216.jpg\n"
+ "100523-Grulee-collection-pediatrics-194x300.jpg";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}