re = /^([^|]*\|[^|]*\|)/m
str = 'TEST|Test2|Test3|Test4'
subst = '$1prefix'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result