Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
(\d*)((\/)\d*)? ([^ ]*) (Alley|Approach|Arcade|Avenue|Boardwalk|Boulevard|Break|Bypass|Chase|Circuit|Close|Concourse|Court|Crescent|Crest|Drive|Entrance|Esplanade|Firetrail|Freeway|Glade|Grange|Grove|Highway|Lane|Loop|Mall|Mews|Parade|Parkway|Passage|Path|Place|Plaza|Promenade|Quays|Ramp|Retreat|Ridge|Rise|Road|Square|Steps|Street|Subway|Terrace|Track|Trail|View|Vista|Walk|Way|Wharf)
/
gm
Input 1
1
New
1/7 Kieller Avenue