#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?iu)(webmoney|сотрудн|коммерческих|заказа|промокод|почта|промокоды|промокоду|промокодом|промокоде|магазин|реклама|реклама|рекламы|4100|подпишись|подписывайся|авторские\sправа|подпишитесь|подписывайтесь|подписаться|присоединяйтесь|нажми|paypal)"
Local $sString = "Реклама" & @CRLF & _
"подпишитесь реклама dfdf 12321 нажми авторские права"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")