use strict;
my $str = 'Реклама
подпишитесь реклама dfdf 12321 нажми авторские права';
my $regex = qr/(webmoney|сотрудн|коммерческих|заказа|промокод|почта|промокоды|промокоду|промокодом|промокоде|магазин|реклама|реклама|рекламы|4100|подпишись|подписывайся|авторские\sправа|подпишитесь|подписывайтесь|подписаться|присоединяйтесь|нажми|paypal)/iup;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}