#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)(?:<div>)(.+?)(?:<\/div>)"
Local $sString = " <div>one</div>" & @CRLF & _
" <div>two</div>" & @CRLF & _
" <div>three</div>" & @CRLF & _
" <div>что-то</div>" & @CRLF & _
" <div>что-то" & @CRLF & _
" еще</div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")