// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?ms)(?:<div>)(.+?)(?:<\/div>)").unwrap();
let string = " <div>one</div>
<div>two</div>
<div>three</div>
<div>что-то</div>
<div>что-то
еще</div>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}