# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\S\(<td>)(.+?)(<\/td>)|(<td><a href\s*=) |(\"[^\"]*\")"
test_str = ("\" <td>PFltLd_stAshRstEEP</td><td><a href=\"PFltLd_AshLoadFuelCnt.htm?1_PFltLd_stAshRstEEP\">AshLoadFuelCnt_1</a><br>\n"
"<a href=\"PFltLd_AshLoadTimeCorr.htm?1_PFltLd_stAshRstEEP\">AshLoadTimeCorr_1</a><br>\n"
"</td>")
subst = "\\1\\2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.