#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^(?:.*)testhack(?:[[:alnum:][:blank:]\\\/\._-]*)(?<!\.git|\.gitignore)$"
Local $sString = "/home/kwaadpepper/testhack" & @CRLF & _
"/home/kwaadpepper/testhack/TwitterReport" & @CRLF & _
"/home/kwaadpepper/testhack/test" & @CRLF & _
"/home/kwaadpepper/testhack/TwitterReport/.git" & @CRLF & _
"/home/kwaadpepper/testhack/TwitterReport/.gitignore" & @CRLF & _
"/home/kwaadpepper/testhack/TwitterReport/LICENSE" & @CRLF & _
"/home/kwaadpepper/testhack/TwitterReport/README.md" & @CRLF & _
"/home/kwaadpepper/testhack/TwitterReport/log_Error.txt" & @CRLF & _
"/home/kwaadpepper/testhack/TwitterReport/log_reported_2015111731047.txt" & @CRLF & _
"/home/kwaadpepper/testhack/TwitterReport/log_reported_2015111761057.txt" & @CRLF & _
"/home/kwaadpepper/testhack/TwitterReport/log_reported_2015111762323.txt" & @CRLF & _
"/home/kwaadpepper/testhack/TwitterReport/log_reported_201511176245.txt" & @CRLF & _
"/home/kwaadpepper/testhack/TwitterReport/log_suspended.txt" & @CRLF & _
"/home/kwaadpepper/testhack/TwitterReport/twitterReport.py" & @CRLF & _
"/home/kwaadpepper/testhack/TwitterReport/twitter_accounts.txt" & @CRLF & _
"/home/kwaadpepper/testhack/TwitterReport/twitter_accounts2.txt" & @CRLF & _
"/home/kwaadpepper/testhack/TwitterReport/twitter_accounts2.txt.save" & @CRLF & _
"/home/kwaadpepper/testhack/TwitterReport/twitter_accounts3.txt" & @CRLF & _
"/home/kwaadpepper/testhack/TwitterReport/.git/HEAD" & @CRLF & _
"/home/kwaadpepper/testhack/TwitterReport/.git/branches" & @CRLF & _
"/home/kwaadpepper/testhack/TwitterReport/.git/config" & @CRLF & _
"/home/kwaadpepper/testhack/TwitterReport/.git/hooks/pre-applypatch.sample" & @CRLF & _
"/home/kwaadpepper/testhack/TwitterReport/.git/hooks/pre-commit.sample" & @CRLF & _
"/home/kwaadpepper/testhack/TwitterReport/.git/hooks/pre-push.sample" & @CRLF & _
"/home/kwaadpepper/testhack/TwitterReport/.git/hooks/pre-rebase.sample" & @CRLF & _
"/home/kwaadpepper/testhack/TwitterReport/.git/hooks/prepare-commit-msg.sample" & @CRLF & _
"/home/kwaadpepper/testhack/TwitterReport/.git/hooks/update.sample" & @CRLF & _
"/home/kwaadpepper/testhack/TwitterReport/.git/info/exclude" & @CRLF & _
"/home/kwaadpepper/testhack/TwitterReport/.git/objects/21" & @CRLF & _
"/home/kwaadpepper/testhack/TwitterReport/.git/objects/4d" & @CRLF & _
"/home/kwaadpepper/testhack/TwitterReport/.git/objects/59" & @CRLF & _
"/home/kwaadpepper/testhack/TwitterReport/.git/objects/69" & @CRLF & _
"/home/kwaadpepper/testhack/TwitterReport/.git/objects/70" & @CRLF & _
"/home/kwaadpepper/testhack/TwitterReport/.git/objects/f9/00faba8624d5cbfee6032ad6266c6722b19457" & @CRLF & _
"/home/kwaadpepper/testhack/TwitterReport/.git/refs/heads" & @CRLF & _
"/home/kwaadpepper/testhack/TwitterReport/.git/refs/remotes" & @CRLF & _
"/home/kwaadpepper/testhack/TwitterReport/.git/refs/tags" & @CRLF & _
"/home/kwaadpepper/testhack/TwitterReport/.git/refs/heads/master" & @CRLF & _
"/home/kwaadpepper/testhack/TwitterReport/.git/refs/remotes/origin" & @CRLF & _
"/home/kwaadpepper/testhack/TwitterReport/.git/refs/remotes/origin/HEAD"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")