$re = '/\b(?|([A-Za-z])([A-Za-z])([A-Za-z])([A-Za-z])([A-Za-z])([A-Za-z])\6\5\4\3\2\1|([A-Za-z])([A-Za-z])([A-Za-z])([A-Za-z])([A-Za-z])[A-Za-z]\5\4\3\2\1|([A-Za-z])([A-Za-z])([A-Za-z])([A-Za-z])([A-Za-z])\5\4\3\2\1|([A-Za-z])([A-Za-z])([A-Za-z])([A-Za-z])[A-Za-z]\4\3\2\1|([A-Za-z])([A-Za-z])([A-Za-z])([A-Za-z])\4\3\2\1|([A-Za-z])([A-Za-z])([A-Za-z])[A-Za-z]\3\2\1|([A-Za-z])([A-Za-z])([A-Za-z])\3\2\1|([A-Za-z])([A-Za-z])[A-Za-z]\2\1|([A-Za-z])([A-Za-z])\2\1|([A-Za-z])[A-Za-z]\1)\b/';
$str = 'radar
racecar
cat
dog
reer
aibohphobia
mouse
house
louse
tattarrattat
supercalifragilisticexpialidocious';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);