re = /^((?:[^\/]+\/){2,4})category\/(?:[^\/]+\/){2}\/?$/m
str = 'country/destinations/itineraries/itinerary/category/region/country/
another/directory/category/region/country/
country/destinations/itineraries/itinerary/
another/directory/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end