using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"my_project\/output\/board1\/build\/foo.*";
string input = @"my_project/output/board1/build/foo-module1
my_project/output/board1/build/foo-module2
my_project/output/board1/build/foo-module3
...
my_project/output/board1/build/foo-module99";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}