use strict;
my $str = '00:00
01:00
02:00
03:00
04:00
05:00
06:00
07:00
08:00
09:00
10:00
11:00
12:00
12:09
12:19
12:29
12:30
12:31
12:32
12:33
12:34
12:35 midday (all days of week)
12:36
13:00
14:00
15:00
16:00
17:00
18:00
19:00
19:35 evening (sun-fri)
20:00
20:05 evening (saturday)
21:00
22:00
23:00';
my $regex = qr/^(0\d:[0-5]\d)|(^1[01]:[0-5]\d)|(^12:[0-2]\d)|(^12:3[0-5])/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}