re = /(<\/?(?:img)[^>]*>)|<[^>]+>/
str = '<dynamic style="font-size: 10pt; line-height: 1.6;"><span style="background-color:#FF0000;">>name<</span></dynamic>
<span style="background-color:#FF0000;">>name<</span>
<span style="background-color:#FF0000;">>name<</span>
<dynamic>>sender<</dynamic>
<dynamic>>email<</dynamic>
<img src="sdfijsdofijsdofijsdoifjsdiof"/>'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result