Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Regular
Expressions
101
Regular
Expressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
^\s*[0-9]+([\,\.][0-9][0-9]{0,2})?$|^$|^\s*$
/
Test String
New