#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "animals\.(?!elephant)\w+"
Local $sString = "animals.fox" & @CRLF & _
" => Result: animals.fox" & @CRLF & _
"animals.kitten" & @CRLF & _
" => Result: animals.kitten" & @CRLF & _
"animals.elephant "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")