# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\b(?:\d+(?:\.\d+)|[a-z\s0-9]+)\b"
test_str = "<Array>\"1bbl\" 2bbl \"is as\" 0.22 \"3\"</Array>"
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.