// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(A[^A]*?B[^B]*?C)").unwrap();
let string = "A|B|A|F|B|C|D|E|F|G
A|B|C|F|B|C|D|E|F|G";
let substitution = "[\\1]";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}