package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b\w+\b`)
var str = ` Art. 3.
1. Grupa producentów rolnych, zwana dalej "grupą", prowadzi działalność jako
przedsiębiorca mający osobowość prawną pod warunkiem, że:
1) została utworzona przez producentów jednego produktu rolnego, zwanego
dalej "produktem", lub grupy produktów w celach określonych w
art. 2,
2) działa na podstawie statutu lub umowy, zwanych dalej "aktem
założyielskim", spełniających wymagania określone w art. 4,
3) składa się z członków, udziałowców lub akcjonariuszy, zwanych dalej
"członkami grupy", z których żaden nie może mieć więcej niż 20% głosów na
walnym zgromadzeniu lub zgromadzeniu wspólników,
4) osiąga co najmniej:
- w pierwszym roku działalności - 51%,
- w drugim roku działalności - 60%,
- w trzecim roku i następnych latach działalności - 75%,
udokumentowanych przychodów ze sprzedaży produktów grupy wytworzonych w
gospodarstwach jej członków,
5) określi obowiązujące członków grupy zasady produkcji, w tym dotyczące
jakości i ilości produktów lub grup produktów oraz sposoby przygotowania
produktów do sprzedaży.
2. Warunek, o którym mowa w pkt 4, obowiązuje po pierwszym roku działalności
grupy.
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}