$re = '/\A(?:(.)(?=.*?(\1\2?)\z))*?.?\2\z/';
$str = 'palindromeemordnilap';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);