$re = '/\.(?!\d{1,3}(\.|$))/m';
$str = '\\\\tom.overflow.corp.com
\\\\123.43.234.23.overflow.corp.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);