$re = '/[\d-_:|\.]+[\d.]+\|([\w]+)/';
$str = '2014-05-21_06:50:59|10.128.3.20|-|-|-|GET|/home.html|-|6';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);