# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*<(\d{1,3}(?:\.\d{1,3}){3})>.*/$1/;t' <<< "%BER-1-887373: Group <Connect> User <gacan> IP <72.34.184.200>"