const regex = /.*<(\d{1,3}(?:\.\d{1,3}){3})>.*/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*<(\\d{1,3}(?:\\.\\d{1,3}){3})>.*', '')
const str = `%BER-1-887373: Group <Connect> User <gacan> IP <72.34.184.200>`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);