use strict;
my $str = '%BER-1-887373: Group <Connect> User <gacan> IP <72.34.184.200>';
my $regex = qr/.*<(\d{1,3}(?:\.\d{1,3}){3})>.*/p;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";