$re = '/^([1-9]\d?|100)$/m';
$str = '1
2
...
10
...
30
...
56
...
67
...
99
100
100
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);