$re = '/(?!=#)#\w+$/';
$str = 'http://localhost/search/s.php?search_query=#hashtag';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);