import Foundation
let pattern = #"(author\s=\s\{+(.*)+\},)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
@article{Cian2014,
abstract = {The aim of the present study was to investigate (1) the relative contribution of the egocentric reference as well as body orientation perception to visual horizon percept during tilt or during increased gravito-inertial acceleration (GiA, hypergravity environment) conditions and (2) the role of vestibular signals in the inter-individual differences observed in these perceptual modalities. Perceptual estimates analysis showed that backward tilt induced (1) an elevation of the visual horizon, (2) an elevation of the egocentric estimation (visual straight ahead) and (3) an overestimation of body tilt. The increase in the magnitude of GiA induced (1) a lowering of the apparent horizon, (2) a lowering of the straight ahead and (3) a perception of backward tilt. Overall, visual horizon percept can be expressed as the combination of body orientation perception and egocentric estimation. When assessing otolith reactivity using off-vertical axis rotation (OVAR), only visual egocentric estimation was significantly correlated with horizontal OVAR performance. On the one hand, we found a correlation between a low modulation amplitude of the otolith responses and straight ahead accuracy when the head axis was tilted relative to gravity. On the other hand, the bias of otolith responses was significantly correlated with straight ahead accuracy when subjects were submitted to an increase in the GiA. Thus, straight ahead sense would be dependent to some extent to otolith function. These results are discussed in terms of the contribution of otolith inputs in the overall multimodal integration subtending spatial constancy.},
author = { Cian, C and Barraud, P A and Paillard, A C and Hidot, S and Denise, P and Ventre-Dominey, J },
doi = {10.1007/s00221-013-3816-6},
issn = {1432-1106},
journal = {Experimental brain research},
keywords = {Adult,Eye Movements,Eye Movements: physiology,Female,Gravitation,Humans,Individuality,Male,Orientation,Orientation: physiology,Otolithic Membrane,Otolithic Membrane: physiology,Psychophysics,Reflex, Vestibulo-Ocular,Rotation,Statistics as Topic,Young Adult},
month = mar,
number = {3},
pages = {1037--45},
pmid = {24430025},
title = {{Otolith signals contribute to inter-individual differences in the perception of gravity-centered space.}},
url = {http://www.ncbi.nlm.nih.gov/pubmed/24430025},
volume = {232},
year = {2014}
}
@article{Cian2014,
abstract = {The aim of the present study was to investigate (1) the relative contribution of the egocentric reference as well as body orientation perception to visual horizon percept during tilt or during increased gravito-inertial acceleration (GiA, hypergravity environment) conditions and (2) the role of vestibular signals in the inter-individual differences observed in these perceptual modalities. Perceptual estimates analysis showed that backward tilt induced (1) an elevation of the visual horizon, (2) an elevation of the egocentric estimation (visual straight ahead) and (3) an overestimation of body tilt. The increase in the magnitude of GiA induced (1) a lowering of the apparent horizon, (2) a lowering of the straight ahead and (3) a perception of backward tilt. Overall, visual horizon percept can be expressed as the combination of body orientation perception and egocentric estimation. When assessing otolith reactivity using off-vertical axis rotation (OVAR), only visual egocentric estimation was significantly correlated with horizontal OVAR performance. On the one hand, we found a correlation between a low modulation amplitude of the otolith responses and straight ahead accuracy when the head axis was tilted relative to gravity. On the other hand, the bias of otolith responses was significantly correlated with straight ahead accuracy when subjects were submitted to an increase in the GiA. Thus, straight ahead sense would be dependent to some extent to otolith function. These results are discussed in terms of the contribution of otolith inputs in the overall multimodal integration subtending spatial constancy.},
author = { Cian, C and Barraud, P A and Paillard, A C and Hidot, S and Denise, P and Ventre-Dominey, J },
doi = {10.1007/s00221-013-3816-6},
issn = {1432-1106},
journal = {Experimental brain research},
keywords = {Adult,Eye Movements,Eye Movements: physiology,Female,Gravitation,Humans,Individuality,Male,Orientation,Orientation: physiology,Otolithic Membrane,Otolithic Membrane: physiology,Psychophysics,Reflex, Vestibulo-Ocular,Rotation,Statistics as Topic,Young Adult},
month = mar,
number = {3},
pages = {1037--45},
pmid = {24430025},
title = {{Otolith signals contribute to inter-individual differences in the perception of gravity-centered space.}},
url = {http://www.ncbi.nlm.nih.gov/pubmed/24430025},
volume = {232},
year = {2014}
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}