import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "enum[^\\{]*\\{\\s*((?!([A-Z][_A-Z0-9]+))\\w+)(,\\s*(?![_A-Z0-9]+)\\w+)*(;[^\\}]*)*\\s*\\}";
final String string = "enum TransparencyState {\n"
+ " one\n"
+ " }\n\n"
+ "enum Blah {\n"
+ " One\n"
+ "}\n\n"
+ "enum TransparencyState {\n"
+ " gone, TRANSLUCENT, OPAQUE_OR_DULL\n"
+ " }\n\n"
+ "enum TransparencyState {\n"
+ " Gone, \n"
+ " translucent, \n"
+ " opaque\n"
+ " }\n\n"
+ "enum Blah {\n"
+ " One, TwO_t\n"
+ "}\n\n"
+ "public enum SearchType {\n"
+ " PARTNO_1,\n"
+ " pART_TYPE;\n\n"
+ " @Override\n"
+ " public String toString() {\n"
+ " return super.toString();\n"
+ " }\n"
+ "}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}