use strict;
my $str = '/bla/asd/f.fasdf';
my $regex = qr/ (?(DEFINE)
(?<unreserved> [-._~[:alnum:]] )
(?<sub_delims> [!$&'()*+,;=] )
(?<pct_encoded> %[[:xdigit:]][[:xdigit:]] )
(?<pchar> @|(?&unreserved)|(?&pct_encoded)|(?&sub_delims) )
(?<seg_nz_nc> (?&pchar)+ )
(?<seg_nz> (?::|(?&pchar))+ )
(?<seg> (?::|(?&pchar))* )
(?<rootless> (?&seg_nz)(?:\/(?&seg))* )
(?<noscheme> (?&seg_nz_nc)(?:\/(?&seg)*) )
(?<absolute> \/(?:(?&seg_nz)(?:\/(?&seg))*)? )
(?<abempty> (?:\/(?&seg))* )
)
^(?:(?&rootless)|(?&noscheme)|(?&absolute)|(?&abempty))$
/ixp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}