# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.)(.{3})\s*/{{:achhd:katalog:$1:$1$2.png}}/g;t' <<< "1234"