#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(.)(.{3})\s*"
Local $sString = "1234"
Local $sSubst = "{{:achhd:katalog:$1:$1$2.png}}"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)