using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.)(.{3})\s*";
string substitution = @"{{:achhd:katalog:$1:$1$2.png}}";
string input = @"1234";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}