const regex = /(.)(.{3})\s*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.)(.{3})\\s*', 'g')
const str = `1234`;
const subst = `{{:achhd:katalog:$1:$1$2.png}}`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);