// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(.)(.{3})\s*").unwrap();
let string = "1234";
let substitution = "{{:achhd:katalog:$1:$1$2.png}}";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}