import Foundation
let pattern = #"(.)(.{3})\s*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"1234"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"{{:achhd:katalog:$1:$1$2.png}}"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)