using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*?<pre>.*\s?((<br\s*?\/?>\s?).*?){1,}<\/pre>";
string input = @"<pre>Match<br /></pre>
<pre>Match<br />Match again<br /></pre>DONT MATCH<br />blablabla
<pre>
<br />
Hard mode : U should have been matched aswell</pre>
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}