package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*?<pre>.*\s?((<br\s*?\/?>\s?).*?){1,}<\/pre>`)
var str = `<pre>Match<br /></pre>
<pre>Match<br />Match again<br /></pre>DONT MATCH<br />blablabla
<pre>
<br />
Hard mode : U should have been matched aswell</pre>
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}