$re = '/\*\*(.+?)\*\*/s';
$str = '**Hello, My name is
Name: enter**
**Designation is:
Field work**dgfdgdf
hfgf';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);