const regex = new RegExp('^(?P<major>0|[1-9]\\d*)\\.(?P<minor>0|[1-9]\\d*)\\.(?P<patch>0|[1-9]\\d*)(?:-(?P<prerelease>(?P<stage>(?:alpha|beta|rc))(?:\\.(?P<feature>(?:(?P<pic>[0-9a-zA-Z-]*)\\.)?[0-9a-zA-Z-]*))?))?(?:\\+(?P<buildmetadata>[0-9a-zA-Z-]+(?:\\.[0-9a-zA-Z-]+)*))?$', 'gm')
const str = `0.2.19-beta.sppe-123+noescape
0.2.19-beta.fix-panic
0.2.18-alpha.zhihua-zeng.performance-improvement-test
0.2.18-rc
0.2.17
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}