import Foundation
let pattern = #"[^a-zA-Z0-9,.\s"](?!(?:"[^"]*"|[^"])*$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"I have some-non-alphanumeric % characters remain here, I "also, have_+ some & .here""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)