$re = '/^(?:[A-Z][a-z]+\.(?:jpg|png|gif),){4,}$/m';
$str = 'Chrysanthemum.jpg,Desert.png,Hydrangeas.gif,Jellyfish.jpg,Koala.jpg,Lighthouse.png,
Chrysanthemum.jpg,Desert.png,Hydrangeas.gif,
Chrysanthemum.jpg,
Chrysanthemum.jpg,Desert.png,
Salvis.jpg,Sumeet.jpg,Jacob.png,Srlawr.png,';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);