using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(['""])(?:(?!\1).)*or(?:(?!\1).)*\1(*SKIP)(*F)|\bor\b";
string input = @"$example or 'default value'
""this or that""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}