import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<br\\s*\\/?>";
final String string = "I have <br> <br asked br> <br />\n\n"
+ "a <br/> <h1>\n\n"
+ "<h1<br>>>>>>\n"
+ "<br>>>>>>>> question <b . <a";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}