#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<![,\.])\b(\d+[,.]\d+)\b(?![.,]\d)"
Local $sString = "| Task| Text | Capture | " & @CRLF & _
"|:---- |:------| :-----|" & @CRLF & _
"| Capture| 1.304 /XXX 0.0000 XX 15/Oct/2000 | 1.304 and 0.000 |" & @CRLF & _
"| Capture | XXX 1.304% - XXXX 15.10.2044 XXX | 1.304 but not part of the date 15.10.2044|" & @CRLF & _
"| Capture| XXX 11,8275% XXX1 AAA | 11,8275|" & @CRLF & _
"| Capture| XX 0.0. vs. 2.895 | 2.895 |" & @CRLF & _
"| Capture| XX 0.0. vs. 2.895. | 2.895 |"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")